Error in my Plugin since 1.17

Hi, since I updated to 1.17 I always get problems with one of my plugins when I start the server. I get this error:
[Server thread / ERROR]: [org.bukkit.craftbukkit.v1_17_R1.util.CraftMagicNumbers] null
com.mojang.brigadier.exceptions.CommandSyntaxException: Expected ‘{’ at position 0: <- [HERE]
The plugin adds new features in form of player heads for the wandering trader.
The error comes when I add a head from the config to an ArrayList. This has only happened since I updated to 1.17.

Here my Classes https://pastecode.io/s/t7yd2xn3
It happens in Miniblocks.java and Heads.java. I have marked the lines