Waterfall build Problems

Hey, i builded my Waterfall.jar but i got this two errors:

  1. [ERROR] The projects in the reactor contain a cyclic reference: Edge between ‘Vertex{label=‘io.github.waterfallmc:waterfall-proxy:1.15-SNAPSHOT’}’ and ‘Vertex{label=‘io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT’}’ introduces to cycle in the graph io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT --> io.github.waterfallmc:waterfall-proxy:1.15-SNAPSHOT --> io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT @

  2. [INFO] Scanning for projects…
    [ERROR] [ERROR] The projects in the reactor contain a cyclic reference: Edge between ‘Vertex{label=‘io.github.waterfallmc:waterfall-proxy:1.15-SNAPSHOT’}’ and ‘Vertex{label=‘io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT’}’ introduces to cycle in the graph io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT --> io.github.waterfallmc:waterfall-proxy:1.15-SNAPSHOT --> io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT @
    [ERROR] The projects in the reactor contain a cyclic reference: Edge between ‘Vertex{label=‘io.github.waterfallmc:waterfall-proxy:1.15-SNAPSHOT’}’ and ‘Vertex{label=‘io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT’}’ introduces to cycle in the graph io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT --> io.github.waterfallmc:waterfall-proxy:1.15-SNAPSHOT --> io.github.waterfallmc:waterfall-api:1.15-SNAPSHOT -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectCycleException

Did you set it up correctly? Or was this from a server host. I’d contact them about it if it was. If not, I’d double check all your server version files are up to date and match. Would you mind telling me what versions you’re running?