[SOLVED] Cannot log onto server after updating, 1.15.2-102

Hello everyone! I recently upgraded paper from version 70-something (I think it was 72 or 74) to the latest version (version 102). Minecraft server version stayed at 1.15.2 consistently.

Following the update nobody can successfully log onto the server. When we log in, one of the following happens

  • The world base is shown (like, the background without the blocks) and nothing loads. For example, my character was in the Nether, so the red background shows, but no blocks show up
  • The player’s inventory shows up (in the case of one other player) but the world does not show up (only the background shows up)
  • The player’s inventory does not show up, but the world does. I experienced this on some logins where my player could move around in the Nether, but the inventory never showed up. Also, an experience orb that I did not collect prior to the server shutdown kept circling me.

All three situations above eventually resolve as a timeout, disconnect, or connection reset by peer. On the server, similar messages appear (keepalive timeout exceeded, lost connection, etc.)

Here is my timings report with plugins listed: https://timings.aikar.co/?id=11af361a6a0d482facd78c5fec92f6e4#timings

I tried disabling LWC because it seemed like something the server was choking on, but it didn’t make any difference. I suppose if it worked on version 70-79 then it should on the latest, since the vanilla JAR is the same (1.15.2).

Please help me out as nobody is able to play on the server anymore :frowning: Thank you!

Sorry, it seems to have been a problem with the server provider. I confirmed by pinging the server, which showed a high number of lost packets. Guess it’s time to migrate away from DigitalOcean… they’ve been quite unstable lately. Sorry for the false alarm everyone.