Players taking a while to load in

Good day.

To preface I am very new to hosting a minecraft server so I am not sure where this should be posted.

When there is someone already on the server, it takes about 6-10 seconds from when you click join till your inventory loads in and you can interact with stuff. It has happened a few times that in this window a creeper has walked up to a player and said hello.
But when the first person loads in, it is pretty much instant.

I have tried looking for people having the same issue but can’t find anything.

I was running 1.15.2 for a while without issue, but now with 1.16.1 it seems to be a problem.
I am going to create a test server to see if it is a version thing.

This is my timings report when I was just logging in and out a few times I reverted back to an older version I first ran
This was me and someone else doing the same

I have changed some settings to see if there is a cominality, but I can only see with the first link that Minecraft::Connection Handler is taking a bit too long. Is this normal? Can I do anything that might be able to help it?

I am running this on a ubuntu 20.04 server.

If there is anything I can do to get more info please let me know.

Kind regards,

your CPU probably fine. It’s either your RAM or your disk.

If you’re self-hosting, make sure your disk isn’t too old or about to give out.

If it’s RAM, try creating a swap file to save on precious RAM.

Hello, thank you for your reply.
It is hosted on a VPS by Contabo running ubuntu
My Ram and CPU look fine. I don’t know how to check disc though.

I tried including an image of the load on the server during an active session, hope it works.

I ran these on the server using this url as a reference

user:~$ sudo hdparm -Tt /dev/sda

Timing cached reads: 19422 MB in 2.00 seconds = 9726.48 MB/sec
Timing buffered disk reads: 1690 MB in 3.00 seconds = 562.76 MB/sec
user:~$ dd if=/dev/zero of=/tmp/output bs=8k count=10k; rm -f /tmp/output
10240+0 records in
10240+0 records out
83886080 bytes (84 MB, 80 MiB) copied, 0.134039 s, 626 MB/s

It looks like the disk is ok as well.