My plugin won't start up


#1

Hey,

I have a plugin that i created and i recently updated it to 1.14.1 but it won’t load in paper.
Here is my log:

[18:11:09 ERROR]: Could not load 'plugins/VenetiusCore.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: Unsupported API version 1.14.1
at org.bukkit.craftbukkit.v1_14_R1.util.CraftMagicNumbers.checkSupported(CraftMagicNumbers.java:252) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:130) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:336) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:256) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.craftbukkit.v1_14_R1.CraftServer.loadPlugins(CraftServer.java:352) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.craftbukkit.v1_14_R1.CraftServer.reload(CraftServer.java:852) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.Bukkit.reload(Bukkit.java:610) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:54) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:736) ~[patched_1.14.1.jar:git-Paper-22]
at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchServerCommand(CraftServer.java:698) ~[patched_1.14.1.jar:git-Paper-22]
at net.minecraft.server.v1_14_R1.DedicatedServer.handleCommandQueue(DedicatedServer.java:457) ~[patched_1.14.1.jar:git-Paper-22]
at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:419) ~[patched_1.14.1.jar:git-Paper-22]
at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:1057) ~[patched_1.14.1.jar:git-Paper-22]
at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:902) ~[patched_1.14.1.jar:git-Paper-22]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]

#2

The only valid api-version values are 1.13 and 1.14. If it’s 1.14, then the plugin won’t work on 1.13.

1.14 and 1.14.1 are API-compatible, so there is no need to worry about setting api-version: 1.14.