Maven Import WEIRD Error?

I LOVE PAPER but there is one thing I dont understand

Everytime I reimport my maven dependencies paper isn’t working correctly
333dd831a3dfb9cc8e858fb5745192e8

Which is quite funny since I somehow have paper things like…
915f2d09d161ddac85d47044675c99b1

Do you know how to fix this? I have this bug everytime and I dont know how to fix it without literally creating a new project everytime LOL

Your sincerely

  • NoRisk :3

Without your pom we cannot help you

<?xml version="1.0" encoding="UTF-8"?>


4.0.0

<groupId>idc</groupId>
<artifactId>idc</artifactId>
<version>1.0-SNAPSHOT</version>
<packaging>jar</packaging>

<name>HG</name>

<properties>
    <java.version>1.8</java.version>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>

<build>
    <defaultGoal>clean package</defaultGoal>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.7.0</version>
            <configuration>
                <source>${java.version}</source>
                <target>${java.version}</target>
            </configuration>
        </plugin>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-shade-plugin</artifactId>
            <version>3.1.0</version>
            <executions>
                <execution>
                    <phase>package</phase>
                    <goals>
                        <goal>shade</goal>
                    </goals>
                    <configuration>
                        <createDependencyReducedPom>false</createDependencyReducedPom>
                    </configuration>
                </execution>
            </executions>
        </plugin>
    </plugins>
    <resources>
        <resource>
            <directory>src/main/resources</directory>
            <filtering>true</filtering>
        </resource>
    </resources>
</build>

<repositories>
    <repository>
        <id>papermc</id>
        <url>https://papermc.io/repo/repository/maven-public/</url>
    </repository>
    <repository>
        <id>sonatype</id>
        <url>https://oss.sonatype.org/content/groups/public/</url>
    </repository>
</repositories>

<dependencies>
    <dependency>
        <groupId>com.destroystokyo.paper</groupId>
        <artifactId>paper-api</artifactId>
        <version>1.15.2-R0.1-SNAPSHOT</version>
        <scope>provided</scope>
    </dependency>
    <dependency>
        <groupId>com.zaxxer</groupId>
        <artifactId>HikariCP</artifactId>
        <version>LATEST</version>
        <scope>compile</scope>
    </dependency>
    <dependency>
        <groupId>org.mariadb.jdbc</groupId>
        <artifactId>mariadb-java-client</artifactId>
        <version>2.5.4</version>
        <scope>compile</scope>
    </dependency>
</dependencies>

Did you refresh your maven dependencies?
If you use IJ you probably need to restart and invalidate caches. IJ has this problem since first 2019 version.