I have a new message

[20:36:32] [Server thread/ERROR]: [[STDERR] ] org.bukkit.craftbukkit.v1_17_R1.legacy.CraftLegacy Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!

If you read one line below it will tell you which plugin is using legacy material or just forgot to specify an api version, you can report it back to the plugin’s author(s).

emm,… no, it doesn’t tell me, just this one…

The output will look like

[16:16:07] [Server thread/ERROR]: [[STDERR] ] org.bukkit.craftbukkit.v1_17_R1.legacy.CraftLegacy Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!
[16:16:10] [Server thread/WARN]: Legacy plugin SuperCoolLegacyOneDotSevenDotTen v1.0.0 does not specify an api-version.

If yours looks different, complain to your host for mangling the console output. But generally there’s nothing you can do about it but talking to the author to use modern material names/specify an api version or get a rid of the plugin.