Help with plugins once again

I know I’ve made a couple posts earlier about custom plugins, but this is another question about those. I want plugins that support 1.8-1.17. If I have a 1.17 server that allows earlier clients to join, what would my external jar be in Eclipse (1.8 or 1.17)?

see server what version? if server version 1.17 it need be 1.17 and same way

Yeah server version 1.17 but I want people 1.8-1.7 to join.

With ViaBackwards (ViaVersion needs to be installed too) people with 1.8 and upwsrds can join, but I dont reccomwnd that bc things like the updated nether from 1.16 will look very bad

yah good point

Thanks