Anti-xray (engine 2) not working in Nether

The anti-xray that’s been readded worked like a charm on my server with minimal memory consumption, even if it’s on engine 2. And that is fantastic. However it seems like it is not be working in the nether.
This is how I filled in my paper.yml, in the anti-xray section.
Is there anything I can do to make it work in the nether, or it’s simply because the function is not implanted yet?

anti-xray:
  enabled: true
  engine-mode: 2
  chunk-edge-mode: 2
  max-chunk-section-index: 3
  update-radius: 2
  hidden-blocks:
  - gold_ore
  - iron_ore
  - coal_ore
  - lapis_ore
  - mossy_cobblestone
  - chest
  - diamond_ore
  - redstone_ore
  - emerald_ore
  - spawner
  - nether_quartz_ore
  replacement-blocks:
  - stone
  - oak_planks
  - netherrack

https://paper.readthedocs.io/en/stable/server/configuration.html#anti-xray
max-chunk-section-index will only protect up to 64 blocks when set to 3

Whoops, so I guess it’s time to increase this a little bit. That solves the issue, thanks a lot.
However, is it possible to make this separated for different dimensions? I’m a little bit worried about my tps.

Create a new config section for your nether world.

How to make that work?

The “default” world is used for settings which aren’t set elsewhere, if you want to override settings for a world, just put the world name into the world-settings section and start overriding stuff from the default one

1 Like

That solves my problems, thanks so much!